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1.0   Introduction 

The EMPower ETSI Burst Measurement System is software supplied by ETS-
Lindgren to work with the EMPower 7002-006 USB RF Power Sensors. The software 
supports up to eight (8) sensors and is compliant with ETSI EN 300 328, v2.1.1. 
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2.0   Installation 

Install the EMPower ETSI Software 

Run the setup.exe file and follow the dialog prompts. 

Install the USB Drivers 

1. Plug the EMPower 7002-006 sensor(s) into any available USB port(s) on the 
computer. 

2. If this is the first time the sensors have been plugged into the computer, 
Windows will attempt to locate device drivers for the sensors. This step will 
likely fail. 

3. Run Control Panel->Device Manager and find the EMPower sensor(s) listed in 
the “Other Devices” section. Double-click the EMPower entry and select Update 
Driver. 

4. Select Browse my computer for driver software and browse to C:\Program 
Files (x86)\ETS-Lindgren\EMPower ETSI\USB Drivers. The USB drivers were 
installed to this directory by the EMPower ETSI installer. 

5. If a security warning appears, select Install this driver software anyway. 
6. Repeat steps 1-5 for each EMPower sensor. When completed, the sensor 

should appear in the Device Manger under the Universal Serial Bus controllers 
section and is listed as “EMPower 7002-006.” 
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3.0   Using the EMPower ETSI Software 

1. Run the EMPower ETSI software from the desktop shortcut or from Start 
Menu\All Programs\ETS-Lindgren\EMPower ETSI. 

2. Select the Configure Sensors button to configure the system (see the 
following section, Configuring the System, for details). 

3. Select Connect to establish communication with the connected sensors. If any 
errors occur, double-check the information you entered in Step 2, and ensure 
that all sensors are plugged into the computer. Also make sure that the 
sensors are listed correctly in Device Manager (see the Install the USB Drivers 
section above). 

4. Select either the Single Capture or Continuous button to begin a trace 
capture. The Graph and Measurement Values are automatically updated when 
new data is acquired. 

5. Once data is acquired, the results can be printed or saved to a report from 
the File menu. 

Report Generation is configured from the File->Options menu, Report Settings tab. 
You can select the report folder and name, specify the output type (HTML, PDF, 
Word, or Excel), and specify the Report Data Format (Graph, Raw Data, or both 
Graph and Raw Data). The default settings are Excel for Report File Type, and 
Graph and Raw Data for Report Data Format. Note: In order to later import the 
report data back into the EMPower ETSI software using the Import Raw Data 
feature, Excel must be selected as the Report File Type, and the Report Data 
Format must include Raw Data, when initially creating the report. 

Configuring the System 

1. Select Configure Sensors from the main panel or go to the Configure-
>Sensors menu option. Note: if sensors are currently configured and 
Connected or an acquisition is in progress, the Configure Sensors button and 
menu option will be disabled. 

2. Set Number of Sensors to the desired value. 
3. For each sensor in the system, enter the USB Identifier located on the sensor 

label (in the format x.x.x.x.x.x.x.x) in the USB IDs column. The correct ID format 
will be validated for each entry when you select OK. Each unique ID that is 
entered in the system will be saved in a list for later use. This list can be 
modified by selecting the Edit USB ID List button. Quick selection of previously 
used IDs is accessed by using the dropdown arrow to the right of each USB ID 
entry. 
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4. For each sensor in the system, select whether to enable corrections and select 
the Correction File path if enabled. Template correction files are supplied for 
each sensor and are simple .csv files in the following format: 

 
frequency1, 
value1 
frequency2, 
value2 

 
where units for frequencies are Hz and units for values are db. These files may 
be edited directly to modify the correction values for each sensor in the system. 
There is no limit to the number of frequency/value pairs that can be added to the 
correction files. The only requirement is that each frequency entry must increase 
in ascending order. 

5. In the Configure Sensors dialog, select whether to use Logarithmic or Linear 
interpolation method for the frequency axis (if any Enable Corrections buttons 
have been turned on). Corrections are applied to sensor readings by using the 
system carrier frequency to look up the correction value using the specified 
interpolation method. 

6. The Time Units can be toggled between milliseconds (ms) and seconds (s) from 
the File->Options, Units tab (also Ctrl-m for milliseconds, Ctrl-n for seconds). 

Import Report Data 

The EMPower ETSI Burst Measurement System software can be used as a data viewer 
and validation tool for previously acquired data.  Any Excel format report that includes 
Raw Data can be loaded back into the system at a later time using the Import Report 
Data tool. Run this tool by selecting File->Import Report Data or pressing Ctrl-I. You will 
be prompted to open an Excel report file. All settings and raw data are extracted from 
the report and reloaded into the user interface. It is important to note that only INPUT 
parameters are loaded into the system, and all OUTPUT values (combined waveform 
data and all measurement values) are recalculated based on these inputs, allowing the 
user to perform validation on the report. For example, specific burst data parameters 
(start time, stop time, or power) can be modified in the Excel file before importing and 
the resulting change in the combined power waveform and the measurement values 
can be observed. Also, post-processing input settings can be changed on the EMPower 
ETSI burst panel to recalculate measurement values on the previously acquired data. 
The post-processing input settings are:  

 Gap Time 

 Threshold Level 

 Assembly Gain 

 Beamforming Gain. 
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Useful Features 

1. All input settings are cached to the hard drive automatically when the test 
panel is closed, and reloaded automatically when starting the software. This 
means that configuration values (Number of Sensors, USB ID strings, 
correction files) should only have to be input once (assuming the config info 
does not change). Upon re-running the software, you can immediately connect 
to the sensors without using the Configure Sensors dialog. 

2. The Graph resizes automatically when resizing main panel. You can use 
Full Screen mode to maximize the graph area. 

3. Data plots can be individually disabled on the Graph by deselecting the 
checkboxes next to each plot entry in the legend. There are numerous other 
built-in graph features accessed from pop-up menus, such as changing plot 
color, Fill Base Line-> -Infinity which makes them bar-chart-like. You can also 
right-click the graph to Export to the clipboard or directly to Excel (you can also 
do this on individual plots from the legend icons). The zoom is very 
straightforward (just select the graph and draw a box) and can be configured in 
the lower left graph palette to zoom horizontally, vertically, or in both axis. There 
is a Full Scale button on the graph to return the axis to full scale after zooming. 

4. The Table View allows for live viewing of the Raw Data in a table format, similar 
to what is available in the Raw Data format for Report Generation files. For each 
sensor configured in the acquisition, the Start Time, Stop Time, and Power are 
displayed in separate columns of the Table. For example, a MIMO system with 3 
sensors would create a total of 9 data columns in the table. In addition, there will 
always be 3 columns allocated to the Combined Start Time, Combined Stop 
Time, and Combined Power of each burst. Finally, there are two calculated 
columns TxOn Time and TxOff Time displayed. 

5. Context Sensitive Help is available by selecting Help->Show Context Help, or 
pressing Ctrl-H. If you move the mouse over controls/indicators, you will see 
Help descriptions for specific input/output values. Press Ctrl-H again to hide 
the Help Window. 

KEYBOARD SHORTCUTS 

1. Once you are connected to the sensors, pressing <Enter> will start a Single 
Capture. 

2. You can tab between each control in a meaningful order. If you have already 
configured sensors and are restarting the software, you can press tab and then 
Enter to Connect, and then Enter again to Single Capture. 

3. <Esc> key will exit the application (or click upper right Windows X, or File->Quit). 
4. You can get to most menu options using either Alt and a shortcut key (Alt F, P 

to print, Alt F, O to show the options dialog, Alt F, S to save report, Alt F, I to 
import report data, Alt F, X to exit, Alt C, F to configure sensors, Alt H, H to 
show context help) or Ctrl-key shortcuts directly (Ctrl-P to print, Ctrl-O to show 
options, Ctrl-S to save report, Ctrl-I to import report data, Ctrl-Q to exit/quit 
system). 
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OTHER USEFUL CTRL SHORTCUTS: 

Ctrl-M = set Time Units to 
milliseconds Ctrl-N = set Time 
Units to seconds 
Ctrl-G = view 
Graph Ctrl-T = 
view Table 

5. F1 will show this User Guide (also accessible from Help->Show User Guide menu 
option). 

Remote Server 

Version 1.0.3 of the software adds the Remote Server feature. The Remote Server 
feature provides a SCPI style interface to the EMPower ETSI Burst Measurement 
System that allows applications to access the EMPower sensors similarly to 
traditional instruments. 

The Remote Server is enabled when the Server indicator is lit on the EMPower 
ETSI Burst Measurement System panel. Additionally, a Remote indicator displays 
when a client has connected to the server. 
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Configuration 

The Remote Server options are accessed from the File->Options menu (or type Ctrl-
O), Remote Server tab. The Remote Server Enabled checkbox enables the server, and 
the Server Port specifies the port address of the server on the host computer. The IP 
address of the host computer, and this Server Port will be needed by the client 
software to access the Remote Server. 

 

Connecting to the Remote Server 

Access the Remote Server as a raw socket from the client software by opening a 
connection to the specified Server Port and IP address of the host computer. This can 
easily be done using VISA (viOpen method) from many software applications (e.g. 
TILE!, LabVIEW, Visual Studio) using the following VISA resource name format: 

TCPIP::<ipaddress>::<port>::SO

CKET where: 
<ipaddress> is the IP address of the host computer. If the client software is running 
on the same computer as the host computer, then use the string “localhost” as the 
<ipaddress>. 
<port> is the Server Port you specified in the Remote Server configuration. 

 
The VISA resource name to access the Remote Server running at the default port 
address, from client software on the same computer, would be: 

TCPIP::localhost::7001::SOCKET 
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COMMUNICATION ISSUES 

Pay special attention to Read terminations when reading from raw socket servers. In 
particular, you will need to set the termination character in your client software to LF 
(0x0A), and enable termination using the termination character. This can be done using 
the viSetAttribute function after opening the VISA resource (attributes 
VI_ATTR_TERMCHAR and VI_ATTR_TERMCHAR_EN, respectively). 

Append a LF to all Write commands in the client software (incoming command 
strings to Remote Server). This will allow proper parsing of input commands by the 
Remote Server software. 

Make sure to set the VISA timeout value to a high enough value to allow for expected 
*OPC? completion times. For example, systems with multiple sensors will take longer to 
complete the Connect command. If the sensor connection takes 20 seconds, a “Connect” 
command followed by “*OPC?” query would need a VISA timeout greater than 20 
seconds to allow the Operation Complete query to complete. 
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REMOTE SERVER COMMANDS 

The following commands and functionality are supported by the Remote Server. 
Command Return Value Description 
*IDN? ETS-Lindgren, ETSI Burst 

Measurement System, ,<version> 
Identification. 

Returns identification string for the 

system, including the vendor 
 1.0.3.10  

*RST none Reset. 
Initiates a reset sequence that attempts 
to make the EMPower sensors ready for 
data collection. This includes connecting 
to the sensors if they are currently 
disconnected, and enabling Continuous 
mode. This function is designed for 
compatibility with off- the-shelf power 
meter drivers and can be followed by 
“Fetch?” to read the combined power 
reading 

  (Max e.i.r.p). Reset can be followed by 
*OPC? to determine when the sequence 
has completed. 

*OPC? Returns “1” when previous command 
has completed 

Operation Complete. 
Use this query command to determine 
when a previous command has 
completed executing. In particular, 
*OPC? can be used following “Connect”, 
“Reset”, or “Start Burst” commands, or 
during Continuous mode acquisition to 
determine when the next frame of data is 
available. 

Connect none Connect. 
Initiates the connection sequence to 
the currently configured sensors. 
Identical to pressing the Connect 
button on the UI. 

Follow this command with a *OPC? query 

to determine when the connection is 

complete. 
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Disconnect none Disconnect. 
Initiates a disconnect sequence 
from the sensors if they are 
currently connected. 

Start Burst none Start Burst. 
 Initiates a single frame acquisition for 

the sensors. Same as pressing the 
Single Capture button on the 

UI. Follow this command with a *OPC? 
query to determine when the acquisition 
is complete. 

Set Continuous <on|off> none Set Continuous. 

Sets Continuous mode On or Off. 

Same as toggling the Continuous 

button on the UI. 

Fetch? Returns the Max e.i.r.p value 
displayed on the UI, which is 
the combined power reading of 
all configured sensors. 

Read Combined Power. 
This command returns the Max e.i.r.p 
reading, in units of dBm. If an acquisition 
is currently in progress when the 
command is received (either Single 
Capture or Continuous mode), the next 
available power reading will be returned. 
If there is no acquisition in progress, the 
last available power reading is returned. 
This function is designed to emulate 
traditional Power Meter functionality and 
can be used to read CW power for 
single sensor configurations, or 
combined power for multiple sensor 
configurations 

Fetch<0 to 8>? 
 
<0 to 8> = Sensor 

Returns the max power of the 
specified Sensor (when Sensor = 
1 to 8), or the max power of the 
combined burst power array 
(when Sensor = 0) 

Read Channel Power. 
This command returns the maximum 
power of individual Sensor burst 
waveforms. For CW input signals, this 
value will represent the CW power of the 
input signal. If an acquisition is currently 
in progress when the command is 
received (either Single Capture or 
Continuous mode), the next available 
power reading will be returned. If there is 
no acquisition in progress, the last 
available power reading is returned. This 
function is designed to emulate traditional 
Power Meter functionality and can be 
used to read CW power for multiple 
sensor configurations. 
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Fetch:<measurement>? 
 
 
 

<measurement>: 

Returns the specified 
measurement value 

Read Measurement. 
This command returns the last 
measured value of a Measurement 
Value displayed on the UI. The following 
measurement values can be returned: 

rms 
 

RMS: 
The Medium Utilisation % represented in 
units of dBm. 

dutycycle 
 

Duty Cycle: 
The sum of all TxOn times divided by 
the observation period. TxOn time is 
defined as the time between the start 
and stop times of each individual burst. 

mingaptime 
 

Min. Gap Time 
Any TxOff time that is greater than the 
Gap Time input setting is considered a 
Tx-gap. Min. Gap Time is the smallest 
such Tx-gap time in the observation 
period. 
Min. Gap Time is expressed in seconds. 
TxOff time is defined as the time 
between the stop and start times of two 
subsequent bursts. 

maxsequencetime 
 

Max. Sequence Time 
The Tx-sequence time is the time 
between two subsequent Tx-gaps. Max. 
Sequence Time is the longest such Tx-
sequence time. Max. Sequence Time is 
expressed in seconds. Any TxOff time 
that is greater than the Gap Time input 
is considered a Tx-gap. 

mediumutilsation 
 

Medium Utilisation 
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burstpulses 

 The Medium Utilisation (MU) factor is a 
measure to quantify the amount of 
resources (Power and Time) used by 
non-adaptive equipment. The Medium 
Utilisation factor is defined by the 
formula: MU = (P/100 mW) × DC 
where: MU is Medium Utilisation factor 
in % 
P is the RF output power as defined in 
clause 4.3.1.1.1 expressed in mW 
DC is the Duty Cycle as defined in 
clause 4.3.1.2.1 expressed in % 
 
Burst Pulses 
The total number of burst pulses in the 
Observation Period. 
Note that this number will be at least 
one smaller than the total bursts listed in 
the Burst Data Table view. This is 
because the last burst is not included in 
the calculations. Additionally, the first 
burst is not included if it starts at time 0. 
(clause 5.4.2.2.1.3, Step 3, v2.1.1) 

Fetch<0 to 8>:<array>? 
 
<0 to 8> = Sensor 

Returns the specified data array 
from the specified Sensor. 
Sensors 1 to 8 are the individual 
sensor’s burst data, and Sensor 0 
is the combined burst data. 

Read Array. 
This command returns data in an array 
format. The returned string is 
represented in a CSV format, where 
each value is a series of characters 
representing a numeric value, 
separated from the next numeric value 
by a comma. 

<array>: 
 

The following arrays can be 
retrieved: 

ontimes 
 

On Times 
An array representing the TxOn 
Times of the burst dataset. 

offtimes  Off Times 
An array representing the TxOff 
Times of the burst dataset. 

burst:x 
 

Burst X 
An array representing the X values of 
the burst data plot. 

burst:y 
 

Burst Y 
An array representing the Y values of 
the burst data plot. 

burst 
 

Burst 
This format includes both X and Y 
values interleaved in the array, so the 
entire X Y plot can be retrieved with a 
single command. 
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  Data[0] = X[0] 
Data[1] = Y[0] 
Data[2] = X[1] 
Data[3] = Y[1] 
Etc. 

Set Carrier Frequency 
<numeric_value> 

none Set Frequency. 
Sets the Carrier Frequency setting, in 
units of Hz. When this command is 
received, the UI input will update. Most  
standard formats are accepted for 
<frequency>, e.g.: 100000000 
100e6 HZ 
100 MHZ 

  0.1 GHZ 

Set Trigger Level 
<numeric_value> 

none Set Trigger Level. 
Sets the trigger level for each 
sensor configured in the 
acquisition, expressed in dBm. 

Set Measure Time 
<numeric_value> 

none Set Measure Time. 

Sets the measurement time period for the 

acquisition, expressed in seconds. 

Set Sample Rate 
<numeric_value > 

none Set Sample Rate. 

Sets the sample rate for the 

acquisition, expressed in 

Samples/Sec (S/s). 
Set Gap Time 
<numeric_value > 

none Set Gap Time. 
Sets the Gap Time (expressed in Seconds) 
for the post-processing analysis of the last 
data set. Any TxOff time that is greater 
than the Gap Time is considered a Tx-gap. 
The minimum of all Tx-gaps in the 
observation period is measured and output 
as the Min. Gap Time measurement value. 
TxOff time is defined as the time between 
the stop and start times of two subsequent 
bursts. 

Set Threshold Level 
<numeric_value > 

none Set Threshold Level. 
Sets the Threshold Level (expressed in 
dBc, or dB to Carrier) for the post-
processing analysis of the last data set. 
Threshold Level is used to determine the 
Start and Stop values of the Combined 
burst data. The Start and Stop times for 
each burst are defined as the points where 
the power is at least Threshold Level dB 
below the highest value of the stored 
(summed) samples. 
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Set Assembly Gain 
<numeric_value > 

none Set Assembly Gain. 
Sets the Assembly Gain “G” (expressed in 
dBi) for the post- processing analysis of the 
last data set. Assembly Gain is the (stated) 
antenna assembly gain "G" in dBi of the 
individual antenna. 

Set Beamforming Gain 
<numeric_value> 

none Set Beamforming Gain. 
Sets the Beamforming Gain “Y” (expressed 
in dB) for the post-processing analysis of 
the last data set. 
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REMOTE SERVER COMPATIBILITY COMMANDS 

The Remote Server supports a small subset of “traditional” Power Meter command 
sets, in order to provide compatibility with some simple Power Meter software 
drivers. 

Note: These commands are loaded dynamically from a configuration file. Additional 
commands may be added in the future. Contact ETS-Lindgren support for requests for 
additional instruments. Note also that the “Fetch?” command is native to both ETSI Burst 
Measurement System and to many traditional power meters, so no compatibility command 
is necessary for instruments that use this function (e.g. R&S NRP, Keysight EPM Series). 

The following table lists some of the included compatibility commands. 
 

Instrument Compatibility Command Native ETSI command 

R&S NRP INIT:CONT <ON|OFF> Set Continuous 

R&S NRP/Keysight EPM SENSE:FREQ <value> Set Carrier Frequency 

R&S NRVD SENSE:CORR:FREF <value> Set Carrier Frequency 

R&S NRVD MEAS? Read Power 

Yokogawa WT1600 :NUMERIC:NORMAL:ITEM4? Read Power 

Wavetek 8502 UPDN Read Power 

ETS-Lindgren EMPower [slot][ch]:FREQUENCY <value> Set Carrier Frequency 

ETS-Lindgren EMPower [slot][ch]:POWER? Read Power 

 


